Heartbeat bug test (CVE-2014-0160)

A major vulnerability in OpenSSL software was announced late yesterday 04/07/2014, impacting all servers having the Heartbeat TLS extension enabled with OpenSSL versions states above.
The "heartbleed" vulnerability, has been already recorded as CVE-2014-0160. Further details can be found at http://heartbleed.com and https://www.openssl.org/news/secadv_20140407.txt.

This is just a simple test to check if you have the Heartbeat TLS extension enabled. If you are not using OpenSSL or the version of OpenSSL is NOT one of 1.0.1f, 1.0.1e, 1.0.1d, 1.0.1c, 1.0.1b, 1.0.1a, 1.0.1, 1.0.2-beta1 your server is most likely not affected.

Enter host:port

For more tests, please visit the WebSitePulse Test Tools section.